Skip to main content
Radius Help Center

Radius System Requirements

To use Radius, you will need an internet connection, a supported web browser, and a CRM.

Web Browser

You'll need to use a supported web browser to log in to Radius. Use the latest stable version of one of these browsers. Make sure that cookies and JavaScript are enabled in your browser. If you're having trouble, you may need to clear the cookies and cache in your web browser.

Customer Relationship Management Tool

Radius supports an integration with Salesforce CRM. If you're using a CRM other than Salesforce, we can still help. Talk with our team. 

You'll need Salesforce Enterprise Edition or higher. Check your organization edition in Salesforce Classic and Lightning by searching Company Information from the Setup screen. 

  • Was this article helpful?